WATS add-on to TestStand

Follow

Comments

10 comments

  • Avatar
    Erik Sandvik Haugstad

    Hello! I am working on a test sequence that will support different types of UUTs. By using precondidtions, some tests are skipped for some UUTs and I dont want these in the report. Is there a way to manage this in TS?

     

    -Erik

  • Avatar
    Tom Andres Lomsdalen

    One way is to delete the step result entry in the result list (Locals.ResultList). You would have to do this in a separate step or as a engine callback.

    You might want to consider using if/else or a Case for this instead (Flow control steps). Uncheck the Run Options>Record Result on the flow steps to skip reporting. this way you will only log result from the executed test steps.

  • Avatar
    Erik Sandvik Haugstad

    Thank you, Tom!

    I have some warnings in my WATS report (e.g "VISA Read in SimplePsuMon.vi->SimplePsuMon.vi.ProxyCaller"), that I would like filtered out. Is there a setting for this?

  • Avatar
    Tom Andres Lomsdalen

    I think this has to be filtered in the VI before returning the Warning (error number) to TestStand. You can try to post the question at the NI TestStand forum: http://forums.ni.com/t5/NI-TestStand/bd-p/330

     

  • Avatar
    Christiene Vergeldedios

    Hi, I'm currently working on to resolve issue about pending UUT reports.  It is previously working good but encountered the issues after migrating to .224 from .226 server.  The reports are not transferred to WATS right now, all are pending.  Can you suggest some action. Thanks a lot.

  • Avatar
    Tom Andres Lomsdalen

    Christiene, check you time settings at the client: https://virinco.zendesk.com/entries/22933457-Time-Synchronization

    If this doesn't help, please email the client log file https://virinco.zendesk.com/entries/28627176-Where-to-find-the-wats-log-file-at-the-Client to support@virinco.com

  • Avatar
    Christiene Vergeldedios

    Thank you so much Tom, so, that's need to be synchronized.  But, the thing is I've tried to re-installed the client, and receive new pre UUT check failures.  I'll get back to you, once figure it out. thanks

  • Avatar
    Christiene Vergeldedios

    So All WATS folder was deleted on the NI user folder.. Get back to you on the UUT report. Thanks

  • Avatar
    Marek Szczygieł

    Why when installing TS add-on the default NI models are removed? This should not be done this way.

  • Avatar
    Tom Andres Lomsdalen

    @Marek. The default NI models are not removed but the installation change the default station model to "WATS_SequentialModel.seq". Depending on the TestStand (TS) version you are running, this is to support "ready-to-run" integration.
    If you use TS 2012 or greater you can change the station model back and still log to WATS. The "WATS_SequentialModel.seq" has to run once in TS to add the WATS report plug-in option.
    I hope this was clarifying.

     

Please sign in to leave a comment.