TestStand, OS, LabVIEW, .NET and WATS Compatibility

Requirements, SW support

TS: TestStand Major version release
OS: Operating System
LV: LabVIEW
VS: Visual Studio (Adapter support)
.NET: Supported DLLs compiled with
WATS: Client version
(..): Partly supported

 

 

TS OS LV VS .NET WATS
3.0 XP 6.1, 7.0 2003 2.0 Not supported
3.1 XP 7.1 2003 2.0 2.3, 3.x, 4.x
3.5 XP 7.1 2003 (2005) 2.0 2.33.x, 4.x
4.0 XP 7.1.1, 8.2.1 2003, 2005 2.0 2.33.x, 4.x
4.1 XP, Vista, (7) 7.1.1, 8.2.1 (2003), 2005 2.0 2.33.x, 4.x
4.2 XP, Vista, (7) 7.1.1, 8.2.1 2005, 2008 2.0 3.x, 4.x
4.5 (2010/SP1) XP, Vista, 7x32, 7x64 8.2.1, 8.5.1, 8.6.1, 2009sp1, 2010sp1 2005, 2008, 2010 [CRL 2.0]:2.0, 2.1, 3.5
[CRL 4.0]:4.0
3.x, 4.x
2012 (5.0) XP, Vista, 7x32, 7x64 2009sp1, 2010sp1, 2011sp1, 2012 2005, 2008, 2010 (2.0)
4.0
4.x
2013 (5.1) XP, Vista, 7x32, 7x64, 8x32, 8x64 2010sp1, 2011sp1, 2012sp1, 2013 (2005), 2008, 2010, 2012 (2.0)
4.0, 4.5
4.x
2014 XP, Vista, 7x32, 7x64, 8x32, 8x64 2011sp1, 2012sp1, 2013sp1, 2014 2010, 2012, 2013 (2.0)
4.0, 4.5
4.x
2016 7SP1, 8.1, 10 2016, 2015 SP1, 2014 SP1, 2013 SP1 2015, 2013, 2012 4.6.1 4.x

 

TestStand: http://www.ni.com/teststand/product_lifecycle/
LabVIEW OS support: http://digital.ni.com/public.nsf/allkb/B972242574D4BB99862575A7007520CB

 

Have more questions? Submit a request

2 Comments

  • 0
    Avatar
    Jouni Reinikainen

    Even this page is written in focus on WATS, I still need to mention following.

    From TestStand support page:

    Additionally, each version of TestStand also typically supports versions of LabVIEW and LabWindows/CVI that are released while the version of TestStand is still in Current Release Support or Mainstream Support. If a maintenance release is available for a version of LabVIEW or LabWindows/CVI, TestStand will support only the maintenance release. 

    If I interpret this TestStand support statement correctly there is a mistake on the table.

    For example, TestStand 2013 supports LabVIEW 2013sp1 (maintenance release) but does not support the LabVIEW 2013 (major release) anymore. Same with 2012 and 2014.

    Or, is there then a conflict with another software?

  • 0
    Avatar
    Tom Andres Lomsdalen

    The list shows the supported software as stated in the major TestStand version release document. Also, TestStand will allow other LabVIEW versions but are not officially supported by NI.

    Supported vs. Allowed but Not Supported (as stated in the NI TestStand release note).

Please sign in to leave a comment.